29 de abril de 2017

BUSCAR V para devolver mas de una columna


Muchas veces nos hemos visto en la necesidad de traer mas de un resultado en nuestras busquedas con BUSCARV, en esta oportunidad veremos como lograrlo.

SINTAXIS de BuscarV Normal : =BUSCARV(Valor a buscar;indicador de columna;ordenado)

Para este ejercicio reemplazaremos en el indicador de columna por esto: ;COLUMNA(I3:M3)-COLUMNA(I3)+2

Quedaria asi: =BUSCARV(A4;H3:M7;COLUMNA(I3:M3)-COLUMNA(I3)+2;0)


Ahora veremos la construccion completa:

Ejemplo: Tengo en mi ejemplo un cuadro de ventas por mes por vendedor.



y deseo buscar de cada vendedor sus ventas mes a mes. En la celda A4 digitaré el vendedor a buscar.

En la cela B4 digitaremos =BUSCARV(A4;H3:M7;COLUMNA(I3:M3)-COLUMNA(I3)+2;0) finalmente CTRL+SHIFT +ENTER para que sea una funcion matricial. 
.
Esta parte de la formula COLUMNA(I3:M3)-COLUMNA(I3)+2 nos permite indicarle que la columna en la que se encuentra es la 2 y asi traer el resultado de cada periodo.



Detalladamente encontraran que no hay referencias en la celdas ($) fijacion de celdas.

Este será nuestro resultado.



DESCARGUE AQUI ESTE EJEMPLO



Otros temas que pueden interesarle:

http://ideasdeexcel.blogspot.com.co/2011/04/videotutorial-buscarv-que-es-y-cuando.html

http://ideasdeexcel.blogspot.com.co/2010/10/funcion-buscarv.html

http://ideasdeexcel.blogspot.com.co/2013/07/funcion-buscarv-sin-coincidencia_27.html

http://ideasdeexcel.blogspot.com.co/2017/02/funcion-buscarv-de-derecha-izquierda.html











Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos

2 comentarios:

  1. Me parece que la fórmula correcta, para que siempre busque el dato clave, sería : =VLOOKUP($A4,$H$3:$M$7,COLUMN(I3)-COLUMN($G3),0)

    ResponderEliminar