17 de junio de 2019

Horas aleatorioas en Excel - funcion aleatorio y aleatorio.entre



 Normalmente pensamos en aleatorio, cuando requerimos numeros, pero en ciertas ocasiones, necesitaremos lo mismo pero para horas.

La funcion aleatorio, y aleatorio.entre normalmente viene para datos numericos, podemos usar otras funciones como texto y apoyarnos para obtener los resultados deseados.
Veamos.




1. Ingrese en cualquier celda, la funcion =TEXTO(ALEATORIO();"hh:mm:ss")

 

2.  Arrastra dicha funcion y verás el increible resultado:




EJEMPLO 2. Ahora queremos que las horas pertenezcan a un rango especiifico, por ejemplo que estén entre las 8: 00 hasta las 12:00


- En la celda D1, escribimos la hora inicial.
- En la celda E1, escribimos la hora final.
- En la celda F1, escribimos la función:
=ALEATORIO.ENTRE(A1*24*60*60;SI(A1>B1;B1+1;B1)*24*60*60)/(24*60*60)
Ahora, prueba a ver si te sirve.

Nota: A la celda F1 dale un formato de hora, o sólo verás un número con decimales.



 Ahora arrastramos la fórmula:







Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos
--> Leer más...

15 de junio de 2019

Validar horas dentro de un Rango - funcion SI y Valor


En esta ocasión tenemos un ejmplo práctico, de rangos de horas, en la cual necesitamos saber a que turno pertenece un rango de horas.
En el ejemplo me especifican datos como:
Turno 1 comprendido entre las 7:01 y las 15:00
Turno 2 comprendido entre las 15:01 y las 22:30

Tenemos además un listado de nuestros empleados, con sus horarios de ingreso y salida. Neceitamos una funcion que nos permita saber a que turno pertenece.

 Funcion VALOR = Convierte una cadena de texto que representa un número en un número.

Sintaxis
VALOR(texto)
La sintaxis de la función VALOR tiene los siguientes argumentos: Rotación Obligatorio. Es el texto entre comillas o una referencia a una celda que contiene el texto que desea convertir.

La función SI le permite realizar una comparación lógica entre un valor y el resultado que espera probando una condición y devolviendo un resultado si es Verdadero o Falso.

La función Y en Excel es una función lógica que nos permitirá evaluar varias expresiones lógicas y saber si todas ellas son verdaderas.

 EJEMPLO: Listado de empleados con horario de llegada y salida.




Requerimos saber a que turno pertenecen los horarios aqui descritos.
En caso que el horario no pertenezca a ningun turno, escribiremos N/A

Nos apoyaremos en las funciones SI y Valor y la funcion Y

La funcion Y unida a la funcion SI, nos permitirá evaluar los rangos de horas, para que escriba por ejemplo turno 1 en el primer rango; turno 2 en el segundo rango o N/A si no pertenece a ninguno.

Veamos.


En la celda E9 escribimos
=SI(Y(C9>=$B$2;D9<=$C$2);"Turno1";SI(Y(C9>=$B$3;D9<=$C$3);"Turno2";"N/A"))


En la B2 tenemos la hora iniciarl del turno 1 y en la C2 la hora final del turno 2, en la fórmula estas deben quedar con referencia absoluta. También sucede lo mismo para B3 y C3.




Este sería el resultado.

Analicemos:
Manuel betancur el resultado nos da N/A porque la hora de inicio pertenece al turno 1 y la hora de salida al turno 2.
Angela Abril el resultado es turno2 porque la hora de llegada es mayor a 3:01 pm y la hora de salida menor que 10:30 pm



 CAMBIE las horas en varios empleados para volver a probar la formula: 
 
 




 Espero les sea de utilidad, quedamos atentos a sus preguntas y comentarios
 

Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos
--> Leer más...

12 de mayo de 2019

Clic derecho no funciona en excel - [SOLUCIONADO]

📊Algunos colegas y amigos nos preguntan como solucionar el 👨‍💻- Error clic derecho en hoja de #Excel - En este video Juan David Zapata uno de nuestros compañeros de soporte te explica como solucionar este inconveniente✅ Visión Tecnológica #ElPoderDeLoSimple 🔴




Pasos:

1. Con Excel cerrado: Abrir Explorador de Windows y clic en pestaña Vista.
2. Chequear la opcion Elementos ocultos.

3. Ir a la ruta  C:\Users\"su-usuario"\AppData\Roaming\Microsoft\Excel
4. Debemos encontrar un archivo llamado excel14.xlb (el numero variará dependiendo de su version de Office) y lo borramos.
5. Abrir Excel y disfrutar nuevamente del correcto funcionamiento del Clic Derecho :)


 



Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos
--> Leer más...

11 de abril de 2019

Solución error en excel luego de instalar Prevalidador Renta.



Nos reportan varios de nuestros usuarios, que luego de haber instalado el prevalidador de Renta, de la dian, presentan una serie de inconvenientes con el Excel en general. 


Hemos realizado investigacion del caso y hoy te traemos una solucion que nos ha dado resultado hasta el momento. 

 


Síntomas


  1. -Al tener una tabla dinamica, no permite ver el listado de campos a la derecha.
  2. -Al dar clic derecho en excel, no aparece el menu desplegable.





Entorno

Puede pasar en cualquier versión de Microsoft Office Excel.




Causas


Previamente instalaron el prevalidador de renta de la dian




Solución




  • Ir a la siguiente ruta:
  • C:\Users\[su usuario]\AppData\Roaming\Microsoft\Excel
  • Dependiendo de su version de excel, encontrará un archivo parecido a este. y se llama Excel15.xlb
  • Debe tener excel cerrado
  • A este archivo, le damos clic derecho, eliminar.
  • Abrimos nuevamente excel, y al hacer pruebas el error estará resuelto.


 


Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos
--> Leer más...