25 de febrero de 2017

Función Buscarv de derecha a izquierda (interesante!)

Quizás hayas notado que la Función BuscarV o ConsultaV  opera de izquierda a derecha y no hay opción  de utilizarla en forma contraria, pero con un poco de ingenio podemos conseguir dicho resultado simulando el funcionamiento de dicha fórmula a través del uso de la funciones elegir, funciones muy potente que pueden ayudarnos a realizar búsquedas.


Veamos este ejemplo:


Si yo busco el nivel salarial (columna de la derecha) obtendré el Salario (columna de la izquierda) esto según la imagen; al hacer la función nos daria un error tal como se muestra en la sgte imagen:



Extrañamente, BUSCARV es la única función de la categoría Búsqueda y referencia que no admite búsquedas hacia la izquierda del valor buscado. ¡¡Con lo fácil que sería poder introducir números negativos en el argumento Columna de búsqueda!!

Bueno, vamos allá:

En este tutorial voy a utilizar las funciones BUSCARV y ELEGIR.

Tengo un listado en el que aparecen los salarios y su nivel dispuestos de esta forma:Columna 1 salarios y columna 2 el nivel. Si yo quisiera buscar el nivel y que me traiga el salario, haremos lo suiguente: Usaremos la siempre util funcion buscar V pero en el rango de busqueda quedara nuestra nueva funcion elegir, veamos: 



Al usar esta función en al celda G7 del ejemplo nos traerá el salario que corresponde al nivel 10.


 Detalle de la formula:   
   Dato a buscar: Es el dato que quieres buscar y desde el cual se comenzará a contar el número de columna de búsqueda.
    Se invierte el orden de las columnas: Aquí está la clave de la fórmula. La matriz (encerrada entre llaves) le dice al resto de argumentos de la función ELEGIR, cuál va en primer lugar y cuál en segundo.
    Primera columna y segunda columna: Son rangos de celdas. En la primera se encuentra el dato que se va a devolver y en la segunda el dato buscado.
    Columna de búsqueda: Es el número de columna donde se encuentra el dato a devolver.
    Exacto: Para hacer una búsqueda exacta o aproximada.

Como te vas a dar cuenta ahora, la columna de búsqueda siempre va a ser 2, ya que solo hay dos columnas que intervienen en la fórmula (la de búsqueda y la de resultado.)

DESCARGA AQUI el ejemplo

Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos

21 comentarios:

  1. Buen día,

    La formula saca error por las llaves, que puedo hacer?

    Gracias

    ResponderEliminar
    Respuestas
    1. Hola! revisa por favor que uses backslash "\" ya que si usas "/" no funciona.

      Eliminar
    2. Hola, ya intente y no da la formula sera que me puede enviar un ejemplo a vic435@hotmail.com gracias

      Eliminar
    3. Ya fue enviada por correo. Habilité la descarga tambien en esta entrada.

      Eliminar
  2. Muchas gracias, al verificarlo en mi excel lo cambio por la coma (,) gracias

    ResponderEliminar
  3. Felicitarlos por la gran ayuda, me salio bien el ejemplo.. gracias

    ResponderEliminar
  4. Saludar la iniciativa de ayudar con estos temas

    ResponderEliminar
  5. Hola , la funcion elegir funciona para el BUSCARH?

    ResponderEliminar
    Respuestas
    1. Creeriamos que si, pero tendriamos que probar a ver, puedes descargar el ejemplo y adaptar para buscarh y confirmar.

      Eliminar
  6. Muchas gracias. Me ha sido de gran ayuda.

    ResponderEliminar
  7. podrias verificar si funciona haciendolo con referencia a otro archivo de excel ya que me manda error. mi correo es jheisonc@gmail.com

    ResponderEliminar
  8. Perfecto, me funciona =BUSCARV(L1;ELEGIR({2\1};$A$1:$A$15;$G$1:$G$15);2;FALSO)

    ResponderEliminar
  9. MUCHAS GRACIAS
    =BUSCARV($H$8,ELEGIR({2,1},G2:G4,$H$2:$H$4),2,0)

    ResponderEliminar
  10. ESTIMADO Y SI QUIERO QUE ME BUSQUE EN UNA SOLA COLUMNA

    ResponderEliminar
    Respuestas
    1. Para BuscarV Siempre le debemos decir QUE buscar, y DONDE buscar. Para este ejemplo estamos buscando en una sola columna que seria A1:A16, cuando sea coindicente B1:B16.
      Si quisiera que me busque el mismo valor y me traiga el mismo resultado, ya no seria util buscarv.

      Eliminar
  11. Hola que tal, mi pregunta es que tal si tengo una matriz de no se... cinco columnas, debo poner en los campos del "elegir" las cinco columnas una por una o se puede trabajar como matriz?

    ResponderEliminar
    Respuestas
    1. Hola, en este caso, solo hay dos columnas que intervienen en la fórmula (la de búsqueda y la de resultado {2\1}) por lo cual no sera posible usar matriz.

      Eliminar
  12. Me ha sido de gran ayuda, muchas gracias!

    ResponderEliminar
  13. FUNCIONA!!, Puto amo, solo tuve que cambiar el \ por coma

    ResponderEliminar
  14. Muchas gracias, me será de gran utilidad

    ResponderEliminar