8 de abril de 2018

Funcion COINCIDIR + CONTAR.SI para saber si mi dato se repite.



En ocasiones, nececsitaremos 1. Saber si mi dato se repite. 2. Donde está e dato que se repite.
Dada esta necesidad, emplearemos las funciones contar.si y coincidir.

La funcion contar.si, como ya sabemos nos ayuda a contar dependiendo de una condicion dada.
La funcion coincidir, me devolverá una posicion dependiendo de una condicion dada.
COINCIDIR devuelve la posición del valor coincidente dentro de matriz_buscada, no el valor en sí. Por ejemplo, COINCIDIR("b",{"a","b","c"},0) devuelve 2, la posición relativa de "b" dentro de la matriz {"a","b","c"}.



Sintaxis:


COINCIDIR(valor_buscado,matriz_buscada, [tipo_de_coincidencia])

   Valor_buscado    Obligatorio. Es el valor que desea buscar en matriz_buscada.
   Matriz_buscada    Obligatorio. Es el rango de celdas en que se realiza la búsqueda.

CONTAR.SI(matriz_buscada, valor_buscado)

  Valor_buscado    Obligatorio. Es el valor que desea buscar en matriz_buscada.
  Matriz_buscada    Obligatorio. Es el rango de celdas en que se realiza la búsqueda.


Ahora para nuestro ejemplo, tenemos este listado de nombres.

 


Deseamos si se repite, cuantas veces y donde.

Primero usaremos la funcion contar.si, para saber cuantas veces. En la celda B1 escribiremos la formula: =CONTAR.SI($A$1:$A$26;A1) . Copiaremos la formula en toda la columna B


Ya con esta sabemos cuantas veces se repite mi dato.

Ahora para saber donde usaremos la funcion coincidir en la celda C1 escribiremos =COINCIDIR(A1;$A$1:$A$26;0)



 Ahora debemos escribir estas dos funciones en una sola celda, además tendremos que usar la funcion SI, para que cuando se repite me diga donde, y en caso que no me coloque cero.


La funcion completa quedaria asi. =SI(CONTAR.SI($A$1:$A$26;A1);COINCIDIR(A1;$A$1:$A$26;0);0)



Esta fórmula arrojará la fila donde está el valor repetido. Es importante recordar que el valor arrojado es el número de la fila dentro del rango fijado, de modo que si el rango es A2:A26 y el valor se repite en la fila 3, en realidad estará en la fila 4, puesto que el rango inicia en la fila 2.





Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos

No hay comentarios.:

Publicar un comentario