3 de junio de 2017

Extraer la primera palabra de una celda ! Funcion Encontrar<--


 Extraer la primera palabra


 Para extraer la primera palabra de una celda utilizamos la función IZQUIERDA y la función ENCONTRAR que nos permitirán de manera practica, encontrar la posición del primer espacio en blanco lo cual me indica donde termina la primera palabra. La fórmula utilizada es la siguiente:


 =IZQUIERDA(A1,ENCONTRAR(" ",A1) -1)


 
 El primer argumento de la función ENCONTRAR es una espacio en blanco " " y al resultado devuelto le resto el número 1 para poder obtener el largo correcto de caracteres de la primera palabra. Observa el resultado:















 Sencillo no? y bastante práctico.

 


Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos

11 comentarios:

  1. Funciona bien pero con una excepcion que no resolver, y es, si el campo solo tiene una letra... ahi da error.
    Tengo celdas con varios palabras y otras que solo tienen una palabra, en estas falla.

    ¿Alguna solucion? Es una cadena muy larga de nombres asique la solucion no es cambiar esa casilla y seguir, tiene que ser la misma formula para todas

    ResponderEliminar
    Respuestas
    1. La solucion es usar la funcion SI.ERROR

      Ejemplo: =SI.ERROR(IZQUIERDA(F8;ENCONTRAR(" ";F8)-1);F8)

      Eliminar
    2. Hola! Gracias Gustavo, esa es una buena solución.

      Otra seria agregar una validación para conocer si el largo es =1 ... Si es verdadero que traiga solo la izquierda de 1 posición.. y sino que traiga la formula antes mencionada.
      Quedaria una formula así: =SI(LARGO(A1=1);IZQUIERDA(A1;1);IZQUIERDA(A1;ENCONTRAR(" ";A1) -1))

      Eliminar
  2. Javier Rincón26 ene. 2019 02:47:00

    Gracias Gustavo, buena solución.

    Enhorabuena

    ResponderEliminar
  3. ESTA SERÍA LA SOLUCIÓN:

    =SI(ESERROR(IZQUIERDA(C276,ENCONTRAR(" ",C276)-1)),EXTRAE(C276,1,999),IZQUIERDA(C276,ENCONTRAR(" ",C276)-1))

    ResponderEliminar
  4. pa la ultima palabra si está grave... alguien ha visto algo?

    ResponderEliminar
    Respuestas
    1. Hola, Puedes encontrar la respuesta en nuestro post. https://ideasdeexcel.blogspot.com/2019/02/extraer-la-ultima-palabra-de-una-celda.html

      Eliminar