29 de abril de 2017

BUSCAR V para devolver mas de una columna


Muchas veces nos hemos visto en la necesidad de traer mas de un resultado en nuestras busquedas con BUSCARV, en esta oportunidad veremos como lograrlo.

SINTAXIS de BuscarV Normal : =BUSCARV(Valor a buscar;indicador de columna;ordenado)

Para este ejercicio reemplazaremos en el indicador de columna por esto: ;COLUMNA(I3:M3)-COLUMNA(I3)+2

Quedaria asi: =BUSCARV(A4;H3:M7;COLUMNA(I3:M3)-COLUMNA(I3)+2;0)


Ahora veremos la construccion completa:

Ejemplo: Tengo en mi ejemplo un cuadro de ventas por mes por vendedor.



y deseo buscar de cada vendedor sus ventas mes a mes. En la celda A4 digitaré el vendedor a buscar.

En la cela B4 digitaremos =BUSCARV(A4;H3:M7;COLUMNA(I3:M3)-COLUMNA(I3)+2;0) finalmente CTRL+SHIFT +ENTER para que sea una funcion matricial. 
.
Esta parte de la formula COLUMNA(I3:M3)-COLUMNA(I3)+2 nos permite indicarle que la columna en la que se encuentra es la 2 y asi traer el resultado de cada periodo.



Detalladamente encontraran que no hay referencias en la celdas ($) fijacion de celdas.

Este será nuestro resultado.



DESCARGUE AQUI ESTE EJEMPLO



Otros temas que pueden interesarle:

http://ideasdeexcel.blogspot.com.co/2011/04/videotutorial-buscarv-que-es-y-cuando.html

http://ideasdeexcel.blogspot.com.co/2010/10/funcion-buscarv.html

http://ideasdeexcel.blogspot.com.co/2013/07/funcion-buscarv-sin-coincidencia_27.html

http://ideasdeexcel.blogspot.com.co/2017/02/funcion-buscarv-de-derecha-izquierda.html











Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos
--> Leer más...

24 de abril de 2017

Función MAX.SI.CONJUNTO



Descripcion:

La función MAX.SI.CONJUNTO devuelve el valor máximo entre celdas especificado por un determinado conjunto de condiciones o criterios.

Sintaxis:
MAX.SI.CONJUNTO(rango_máximo; rango_criterios1; criterios1; [rango_criterios2; criterios2];...)


  Sintaxis detallada






















EJEMPLO
PARA ESTE EJEMPLO DESEAMOS SABER 3 Cosas,
1. EL MAX VALOR Total para un producto para una bodega especifica.
2. Deseamos saber quien es el vendedor
3. Deseamos saber el nombre de ese vendedor,

Aqui podremos hacer uno de varias funciones excelentes en excel.




SOLUCION:

1. En la celda B4 usaré la función =MAX.SI.CONJUNTO(G7:G19;E7:E19;"11677";C7:C19;"1") con los criterios, que el producto = 11677 y la Bodega =1  La cual nos da como resultado 937.500 que seria el valor total maximo cuando se cumplen las condiciones que el producto sea 11677 y la bodega sea la 1.



2.Si ahora complocamos un poco mas el proceso, deseamos saber cual es el vendedor de ese producto. Para esto pensariamos en BuscarV. Pero tenemos el inconveniente que el valor buscado que en este caso seria el resultado de la funcion anterior, se encuentra a la derecha del valor a encontrar que es el vendedor Columna 1.  Para este caso necesitariamos usar la funcion Buscar V pero de derecha a izquierda,

Usamos esta funcion en la celda C4=BUSCARV(B4;ELEGIR({2\1};$A$8:$A$19;$G$8:$G$19);2;0)
VER MAS DETALLES DE ESTA EN http://ideasdeexcel.blogspot.com.co/2017/02/funcion-buscarv-de-derecha-izquierda.html




3.  Ahora si usaremos la funcion conocida que es Buscarv Para traer el nombre del vendedor en la celda D4= =BUSCARV(C4;A8:B19;2;0)



ESPERO HAYA SIDO DE GRAN UTILIDAD!


Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos
--> Leer más...