22 de abril de 2014

Podemos cambiar el formato de un texto usando la Función TEXTO

En muchas ocasiones tenemos texto al que deseamos darle formato de moneda, concatenarlo con texto, ponerlo como fecha y normalmente seleccionamos la celda y definimos un formato, ahora es posible con una fórmula llamada TEXTO ¿Qué tan beneficioso es usarla?, te mostraremos excelentes ejemplos.




Definición: Esta función nos permite convertir un valor en texto, con un formato específico.

Sintaxis de la función :   =TEXTO(valor; formato) los cuales son Obligatorios.
Valor es un valor numérico, una fórmula que evalúa un valor número o una referencia a una celda que contiene un valor numérico. Formato  es un número en forma de texto del cuadro Categoría, pestaña Personalizada del cuadro de diálogo Formato de Celdas, distinto de la categoría General.
.


Esta función es realmente útil cuando deseamos dar formato a un número antes de ser concatenado con otra cadena de texto.

Veamos ejemplos con números


En la celda A1 tenemos el texto 1500 y deseo convertirlo en $ 1.500 para lo cual utilizo la siguiente fórmula =TEXTO(A1; "$0,00") obteniendo el resultado


otros formatos personalizados para números son:

"#,##0" el El cual quita los decimales redondeando el valor y le coloca el separador de miles.
"0%" el cual convierte el valor a porcentaje.


Veamos ejemplos con fechas


En la celda A2 tengo el texto 15/04/2014 y deseo convertirlo en el 15-04-2014 para lo cual utilizo la siguiente fórmula = TEXTO (A2;"dd-mm-yyyy") obteniendo el resultado


.

otros formatos personalizados para fecha son:

"aaaa" muestra el día de esa fecha por ejemplo martes
"m" muestra el mes de esa fecha de forma numérica por ejemplo 4 con solo un dígito
"mm" muestra el mes de esa fecha de forma numérica por ejemplo 04 con dos dígitos
"mmm" muestra el mes de esa fecha de forma de texto por ejemplo Abr solo tres dígitos
"mmmm"  muestra el nombre del mes completo Abril
Use de la misma forma "d" para traer los días en las diferentes formas y "y" para el año.


Veamos un ejemplo para concatenar texto con fechas o números


El resultado obtenido es "Valor a pagar total $1500,0"

Esta y muchas otras funciones las podrás aprender en nuestro curso de excel http://www.visiontecnologica.com/curso/comprarDVD.html  

Si te gustó, síguenos en Twitter  para recibir nuestras actualizaciones y trucos

2 comentarios:

  1. Gracias por tus aportes, me fue de mucha utilidad.

    ResponderEliminar
  2. Tengo un archivo que me muestra las fechas Ej: 24-09-2008, al darle F2 la cambia a 24/09/2008 lo cual me sirve para realizar mis tablas dinamicas, el problema es que son mas de 65222 datos y no es practico presionar F2 de principio a Fin, y en la opcion de cambiar Formato, le pongo Fecha pero no lo cambia, como puedo hacer para cambiar este formato a fecha,en la misma columna sin agregar ninguna otra columna???

    ResponderEliminar