12 de abril de 2012

¿En qué fila de una hoja de cálculo está el valor que se repite?

Identificar si un valor se repite en Excel es relativamente sencillo, pero identificar además en qué fila está dicho valor repetido, es un poco más complejo.

Para saber si un valor se repite en un rango determinado de celdas, se utiliza la función CONTAR.SI  de la siguiente forma:

CONTAR.SI(Rango a buscar;Valor a buscar)


Por ejemplo en la columna A están todos los nombres de los empleados y queremos saber si "Pedro" está repetido.

En la columna B vamos a usar la fórmula de la siguiente manera:

=CONTAR.SI(A1:A9;"Pedro")

El resultado será en número de veces que se encuentra "Pedro" en la lista


Ahora necesitamos identificar en qué fila está ese valor repetido. Para ello se utiliza la función COINCIDIR de la siguiente forma:

=COINCIDIR("Pedro";A1:A9;0)

El resultado será el número de la fila en que se encuentra el valor. En nuestro ejemplo es la fila 4


Las dos fórmulas se pueden unir para hacer el proceso en un solo paso. Quedaría de la siguiente forma:

=SI(CONTAR.SI(A1:A9;"Pedro");COINCIDIR("Pedro";A1:A9;0);0)

Se añade un  SI condicional, de tal forma que si el valor Pedro se repite, entonces la función COINCIDIR hará su trabajo, de lo contrario arrojará cero.

Para simplificar los procesos, en lugar de escribir en la fórmula el valor buscado, se escribe una referencia a la celda donde esté el valor buscado. Por ejemplo, el empleado a buscar puede estar en la celda A4 quedando la fórmula de la siguiente forma:

=SI(CONTAR.SI(A1:A9;A4);COINCIDIR(A4;A1:A9;0);0)

Igualmente se puede hacer más sencilla la fórmula si en lugar del rango se trabaja con nombres de rango. Por ejemplo, al rango A1:A9 se le asigna el nombre de Empleados. Con ello la fórmula podría quedar así:

=SI(CONTAR.SI(Empleados;A4);COINCIDIR(A4;Empleados;0);0)

Tomado de: Gerencie.com


Si te gustó, suscríbete al Feed RSS de Ideas de Excel  y recibe nuestras actualizaciones

No hay comentarios.: